воскресенье, февраля 12, 2017

Установление соседства EIGRP


Всем привет. Сегодня мы попробуем чуть-чуть глубже копнуть протокол EIGRP, и разберемся с вопросом установления соседства между двумя маршрутизаторами, на которых запущен этот протокол динамической маршрутизации. Ну что-же, начнем.
Для начала создадим вот такую простенькую сеть в Packet Tracer
Тестовая сеть для изучения установления соседства EIGRP
Тестовая сеть для изучения установления соседства EIGRP
Выполним настройку маршрутизаторов следующим образом:

Маршрутизатор 0:

Router(config)#interface fastEthernet 0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown 
Router(config)#router eigrp 200
Router(config-router)#network 192.168.1.0

Маршрутизатор 1:

Router(config)#interface fastEthernet 0/0
Router(config-if)#ip address 192.168.1.2 255.255.255.0
Router(config-if)#no shutdown 

Если вы подумали, что мы ошиблись в настройке Маршрутизатора 1, то это не так. Мы специально пока не включаем на нем протокол EIGRP, чтобы запустить его в нужный нам момент, для подробного отслеживания процесса установления соседства. 

Для начала запустим на маршрутизаторе 1 следующий дебаг:

Router#debug ip packet 

В его выводе мы увидим примерно следующее:

IP: s=192.168.1.1 (FastEthernet0/0), d=224.0.0.10 len 20, rcvd 2
IP: s=192.168.1.1 (FastEthernet0/0), d=224.0.0.10 len 20, rcvd 2
IP: s=192.168.1.1 (FastEthernet0/0), d=224.0.0.10 len 20, rcvd 2

Какой вывод мы можем сделать из данной информации? Маршрутизатор 0 со своего интерфейса с адресом 192.168.1.1 выполняет регулярную рассылку Hello сообщений протокола EIGRP, так как он на нем уже запущен, на мультикаст адрес 224.0.0.10. Так как на маршрутизаторе 1, EIGRP еще не запущен, то хоть он и принимает эти Hello сообщения, он их просто игнорирует.

Теперь выполним на маршрутизаторе 1, следующие команды, которыми мы запустим на нем функционирование протокола EIGRP:

Router(config)#router eigrp 200
Router(config-router)#network 192.168.1.0

А после этого в выводе дебага увидим:

IP: s=192.168.1.2 (local), d=224.0.0.10 (FastEthernet0/0), len 20, sending broad/multicast
IP: s=192.168.1.1 (FastEthernet0/0), d=224.0.0.10 len 20, rcvd 2

%DUAL-5-NBRCHANGE: IP-EIGRP 200: Neighbor 192.168.1.1 (FastEthernet0/0) is up: new adjacency







Первая строка говорит нам о том, что маршрутизатор 1 тоже начинает отправлять Hello сообщения протокола EIGRP на мультикаст адрес 224.0.0.10. Вторая строка говорит о том, что маршрутизатор 1 все еще принимает Hello сообщения от маршрутизатора 0. Строка 3 говорит об установлении соседства между маршрутизаторами 0 и 1.

Тоже самое но более подробно можно посмотреть при помощи другого дебага. Для этого гасим EIGRP на маршрутизаторе 1 при помощи команды:

Router(config)#router eigrp 200
Router(config-router)#no network 192.168.1.0

Запускаем дебаг:

Router#debug eigrp packets 

Опять включаем EIGRP на маршрутизаторе 1 и наслаждаемся следующей картиной:

EIGRP: Sending HELLO on FastEthernet0/0
  AS 200, Flags 0x0, Seq 2/0 idbQ 0/0 iidbQ un/rely 0/0

EIGRP: Received HELLO on FastEthernet0/0 nbr 192.168.1.1
  AS 200, Flags 0x0, Seq 2/0 idbQ 0/0

%DUAL-5-NBRCHANGE: IP-EIGRP 200: Neighbor 192.168.1.1 (FastEthernet0/0) is up: new adjacency

EIGRP: Sending HELLO on FastEthernet0/0
  AS 200, Flags 0x0, Seq 2/0 idbQ 0/0 iidbQ un/rely 0/0

EIGRP: Enqueueing UPDATE on FastEthernet0/0 nbr 192.168.1.1 iidbQ un/rely 0/0 peerQ un/rely 0/0 serno 2-2
EIGRP: Requeued unicast on FastEthernet0/0

EIGRP: Sending UPDATE on FastEthernet0/0 nbr 192.168.1.1
  AS 200, Flags 0x1, Seq 2/0 idbQ 0/0 iidbQ un/rely 0/0

EIGRP: Received UPDATE on FastEthernet0/0 nbr 192.168.1.1
  AS 200, Flags 0x1, Seq 2/0 idbQ 0/0
 iidbQ un/rely 0/0 peerQ un/rely 0/0

EIGRP: Sending ACK on FastEthernet0/0 nbr 192.168.1.1
  AS 200, Flags 0x0, Seq 0/2 idbQ 0/0 iidbQ un/rely 0/0

EIGRP: Received ACK on FastEthernet0/0 nbr 192.168.1.1
  AS 200, Flags 0x0, Seq 0/2 idbQ 0/0
 iidbQ un/rely 0/0 peerQ un/rely 0/0

EIGRP: Received HELLO on FastEthernet0/0 nbr 192.168.1.1
  AS 200, Flags 0x0, Seq 3/0 idbQ 0/0

EIGRP: Sending HELLO on FastEthernet0/0
  AS 200, Flags 0x0, Seq 3/0 idbQ 0/0 iidbQ un/rely 0/0

EIGRP: Received HELLO on FastEthernet0/0 nbr 192.168.1.1
  AS 200, Flags 0x0, Seq 3/0 idbQ 0/0

Первые три строки я думаю вам уже и так понятны, они говорят нам о установлении соседства. Четвертая строка тоже нам вполне понятна. А вот пятая строка довольно интересная. Сообщение EIGRP: Enqueueing UPDATE говорит нам о том, что маршрутизатор 1 поставил свое обновление в очередь для отправки на маршрутизатор 0. Строка EIGRP: Sending UPDATE говорит о том, что он отправляет это обновление. А следующая строка EIGRP: Received UPDATE говорит о том, что маршрутизатор 1 получил аналогичное обновление от маршрутизатора 0. Строка EIGRP: Sending ACK является подтверждением маршрутизатора 1,  о получении обновления от маршрутизатора 0. Строка EIGRP: Received ACK являеться подтверждением получения обновления от маршрутизатора 1 маршрутизатором 0. Остальные строки, как вы уже сами понимаете, говорят о штатной отсылке Hello пакетов.

Надеюсь вам было интересно почитать эту статью. На сегодня это все.


0 коммент.:

Отправить комментарий


Поддержи проект "Сетевые заморочки"

руб.