понедельник, декабря 03, 2012

Управление оборудованием Cisco Systems

Мы уже рассмотрели несколько вопросов, посвященных конфигурированию устройств компании Cisco Systems, но каждый раз при настройке оборудования, мы условно принимали, что мы подключены к нему через консольный порт (также как мы это делали в самой первой статье  «Если ты впервые увидел циску»). Согласитесь, это далеко не всегда удобно. Намного приятнее сидеть в своем теплом креселке и удаленно настраивать свой коммутатор, маршрутизатор или любую другую железку. Поэтому сегодня мы обсудим различные варианты подключения к устройствам фирмы Cisco, для их последующего конфигурирования.
Вариант первый – консольный порт

Хотя данный вариант был уже рассмотрен нами ранее. Вернемся к нему еще раз и поговорим о нем чуть подробнее. Данный тип подключения используется в следующих случаях:
  • При первоначальной настройке оборудования
  • Если что то сломалось и вы не можете получить удаленный доступ к оборудованию
  • Если вы находитесь рядом с оборудованием

Для того чтобы отработать его в Packet Tracer разместим в рабочей области коммутатор Catalyst 2960, и один компьютер. Далее с помощью консольного кабеля соединим интерфейс RS-232 компьютера с консольным портом нашего коммутатора. Получившаяся схема будет иметь следующий вид.
Компьютер подключен к коммутатору консольным кабелем
Теперь для того, чтобы подключиться с компьютера к нашему коммутатору через консоль, щелкните два раза левой кнопкой мыши по изображению компьютера, перейдите на вкладку Desktop и выберите приложение Terminal.
Открываем Terminal
Не изменяйте настройки открывшееся в новом окошке, а просто нажмите на кнопку  «ОК» и вы будете подключены к коммутатору через консольный порт.
Вы подключились к коммутатору через консольный порт
Все то, что мы только что проделали равносильно тому, как если бы соединили обычный компьютер с коммутатором через консольный порт, открыли бы на компьютере гипертерминал или putty и подключились бы к коммутатору.

Если вы могли заметить, то когда мы подключаемся к коммутатору через консольный порт, то при настройках по умолчанию он не запрашивает у нас ни логина, ни пароля. Что само по себе является несколько палевным. Представьте, что к вашей железке может подойти любой дядька, воткнуться в нее кабелем и подправить ваш конфиг. Конечно, это маловероятно, ведь ваш коммутатор надежно закрыт за «чугунной» дверью серверной (хочется на это надеяться), но все же лучше разобраться в этом вопросе, ведь безопасность лишней не бывает.

В простейшем случае для, того чтобы ваш коммутатор запрашивал данные пользователя для доступа через консольный порт, на коммутаторе в режиме конфигурирования требуется выполнить следующие команды:

    Switch(config)#username test privilege 1 password 123
    Switch(config)#line console 0
    Switch(config-line)#login local

С помощью команды «username test privilege 1 password 123» мы создаем на коммутаторе локальную учетную запись пользователя с именем test. Выражение «privilege 1» означает, что данному пользователю назначаем минимальный уровень привилегий (На практике это означает что при подключении к коммутатору под данной учётной записью пользователь окажется в непривилегированном режиме, но ни что не мешает ему перейти в привилегированный режим выполнив команду «enable». Если же выставить «privilege 15», то пользователь сразу же после входа будет попадать в привилегированный режим). Выражение «password 123» устанавливает, создаваемой учетной записи пароль 123. Команда «line console 0» позволяет перейти к конфигурированию линии консоли. Команда «login local» указывает, что при подключении через консоль требуется запросить у пользователя его логин и пароль, и при этом необходимо использовать локальную базу учетных записей. 

Если же вы хотите сделать чтобы при подключении через консольный порт запрашивался только пароль, то можно сконфигурировать линию консоли следующим образом:

    Switch(config)#line console 0
    Switch(config-line)#password 123
    Switch(config-line)#login

При такой конфигурации пользователю при входе не придется вводить имя пользователя, а для получения доступа достаточно будет ввести пароль, который задавался командой «password».

Так же для линии консоли вы сможете настроить еще несколько параметров, которые смогут немного повысить безопасность вашей системы. Узнать что это за параметры вы сможете перейдя к конфигурированию линии консоли с помощью «line console 0» и выполнив команду «?».








Вариант второй – подключение к порту AUX

Порт AUX можно использовать для доступа к оборудованию, так же как и консольный порт. Обычно необходимость в использовании данного порта возникает, в том случае если вы что то перемудрили в конфигурации консольного порта. Так же данный порт позволяет подключить к устройству модем, и с помощью него выполнять удаленный мониторинг  и управление оборудованием. Такая возможность используется не очень часто (но все же о ней стоит помнить), поэтому мы не будем рассматривать ее в данной статье.

Вариант третий – удаленное управление с помощью web-интерфейса

Честно сказать данный вариант в жизни ни разу не использовал, так что буду рассказывать вам, так сказать, свои теоритические предположения (в данный момент нет ненужной железки на которой можно было бы проверить, в Packet Tracer данный вариант конфигурирования не предусмотрен) по поводу конфигурирования данного варианта.

И так предполагаем, что наш удаленный компьютер подключен к порту коммутатора, который находится в vlan 1. Компьютер имеет ip адрес 192.168.1.2 с маской 255.255.255.0 и шлюзом по умолчанию 192.168.1.1. Для того чтобы настроить связь с компьютера с коммутатором настроим последний  следующим образом:

    Switch(config)#interface vlan 1
    Switch(config-if)#ip address 192.168.1.1 255.255.255.0
    Switch(config-if)#no shutdown

После чего на компьютере необходимо открыть браузер и попробовать получить доступ к http://192.168.1.1.

Обычно оборудование фирмы Cisco, не конфигурируется с помощью web-интерфейса. Все изменения конфигурации выполняются с помощью консоли, так как она позволяет выполнять более гибкое (и порой недоступное в web-интерфейсе) и безопасное конфигурирование. Поэтому могу посоветовать вам отключить доступ к вашему оборудованию при помощи web-интерфейса, для этого потребуется отключить действующий на оборудовании web-сервер, это можно выполнить с помощью следующих команд:

    Router(config)#no ip http server
    Router(config)#no ip http secure-server

Вариант четвертый – telnet

Используя telnet вы сможете удаленно конфигурировать свое оборудование (да да именно, то о чем мы говорили в начале статьи, вы будите седеть в своем удобном креселке и настраивать ваше железку ).

Для того чтобы отработать данный вариант, соберем в Packet Tracer следующую схему:
Тестовая схема
Компьютеру опять же зададим ip адрес 192.168.1.2 с маской 255.255.255.0 и шлюзом по умолчанию 192.168.1.1. Циску сконфигурируем следующим образом:

    Switch(config)#interface vlan 1
    Switch(config-if)#ip address 192.168.1.1 255.255.255.0
    Switch(config-if)#no shutdown
    Switch(config-if)#exit
    Switch(config)#line vty 0 4
    Switch(config-line)#password 123

С первыми четырьмя строчками все ясно – это мы задаем ip адрес нашему коммутатору (если он у вас уже задан, то их, как вы понимаете, можно и не выполнять). Используя команду «line vty 0 4» мы переходим к конфигурированию линий виртуальных терминалов. Командой «password 123» мы задаем пароль 123 для доступа (если же эту команду не выполнять то при попытке подключения к устройству мы получим - Connection to 192.168.1.1 closed by foreign host). Выполнив данные команды попробуем удаленно подключиться к  коммутатору, для этого перейдем к консоли нашего компьютера и введем команду «telnet 192.168.1.1», если все сделано верно то вы получите доступ к консоли вашего оборудования.
Использование telnet для получения доступа к консоли оборудования
Если же вы хотите чтобы при доступе через telnet у вас запрашивался не только пароль, но и еще и логин пользователя, то сконфигурируйте линии виртуальных терминалов следующим образом:

    Switch(config)#line vty 0 4
    Switch(config-line)# login local

Тока не забудьте перед этим создать на оборудовании учетную запись пользователя.

Вариант пятый – ssh

Наверное, многим могло показаться, что настроив соединение через telnet мы успокоимся. Но не тут то было. На самом деле данные, которые вы передаете через telnet, передаются в незашифрованном виде, а это означает что какой то очень умный малый может их перехватить. Чтобы этого не допустить используют ssh, который шифрует передаваемые данные. Для того чтобы настроить ssh на нашем оборудовании выполним следующие команды:

    Router(config)#hostname test
    test(config)#ip domain name test.test
    test(config)#username test password 123
    test(config)#ip ssh version 2
    test(config)#crypto key generate rsa
    test(config)# line vty 0 4
    test(config-line)#transport input ssh
    test(config-line)#login local

Первые две команды задают домен и имя хоста. Может  показаться, что они лишние, но они необходимы для генерации ключа, которая будет производиться пятой командой. Команда «ip ssh version 2» указывает оборудованию использовать ssh версии 2. Командой «transport input ssh» мы указываем, что подключении к линиям виртуальных терминалов возможно только с использованием ssh.

Все рассмотренное в этой статье способы подключения к оборудованию смогут пригодиться вам в реальной жизни, но в Packet Tracer они довольно бесполезны, так как получить доступ к консоли оборудования можно всего лишь двойным щелчком по нему. 

33 коммент.:

Другие источники советуют вместо password использовать secret, т.к. пароль, в таком случае будет хранится зашифрованным в конфигурационном файле. Думаю стоит об этом сказать если прозвучало слово безопасность =) Спасибо.

Сорри за комент, прочитал следующую статью.

Нет, в данном случае все правильно. Команду secret используют только в том случае если хотят указать пароль, хранящийся в зашифрованном виде, для перехода в привеллигированный режим (используют enable secret вместо enable pas). В данной статье команда enable pas не рассматривалась. Просто взять и заменить слово password на secret во всех командах данной статьи НЕЛЬЗЯ.

Сделал все как написано, через телнет не могу зайти. в чем проблема?

PC>telnet 192.168.1.1
Trying 192.168.1.1 ...Open

[Connection to 192.168.1.1 closed by foreign host]
вот что выдает

Сбросьте конфигурацию вашего устройства, посмотрим.
P.S. не забудьте удалить (или заменить *) из конфигурации все пароли и критически важные моменты.

Я разобрался, спасибо большое! Когда вводил line vty 0 4, 0 и 4 не разделял пробелом. Исправил, все заработало. Только вот вопрос, ПК подключен к коммутатору, к этому SW подключено еще два SW, их я удаленно вижу и захожу, подключаю 3-й и на него зайти не могу. Пробовал, на порт, для 3 SW, подключать один из двух имующихся, все работает. Сколько вообще можно подключить sw?

Такой вопрос а вы можете пропинговать с ПК IP адрес SW3? Если нет, то у вас скорее всего неверно настроен транк со стороны коммутатора SW3.

Опять же, если хотите, сбросьте конфиги всех устройств. Посмотрим.

Спасибо! Я хочу сам попробовать под разобраться. Если не получится, то тогда Вам скину конфиги.

У меня еще один вопрос, я удаленно захожу на SW1, и с него не могу ни зайти ни на один SW ни пингануть, а с ПК все получается. В чем может быть проблема? или так нельзя? Все SW находятся в одном вилане

Этот комментарий был удален автором.

По умолчанию так быть не должно. Когда пытаетесь подключиться с помощью telnet с одного sw на другой что вам выдает: Connection to closed by foreign host иле же Connection timed out; remote host not responding? Если первый вариант то тут, либо неверно настроены линии vty на втором коммутаторе (что вряд ли, так как вы можете подключиться к нему с хоста) или же что более вероятно на коммутаторе имеется ACL запрещающий подключение. Например если у меня есть схема ПК 192.168.1.1-SW1 192.168.1.2 - SW2 192.168.1.3 и я размещу на линиях vty sw2 ACL вида:
SW2(config)#access-list 1 permit host 192.168.1.1
SW2(config)#access-list 1 deny any
то я смогу свободно подключаться на него с пк, но при помытке подключения по телнет с SW1 мне будет выдавать Connection to closed by foreign host. Если дело не в ACL, то отпишитесь, будем думать дальше.

При подключении выдает Connection timed out; remote host not responding. У меня все SW в одной сети, а маски у всех разные. когда сделал у 2-х SW маски одинаковые все заработало. Так и должно быть? Или в пределах одной сети должен быть допуск независимо от маски?
Как же тогда управляют большими сетями?

В пределах одной сети в идеале (но не обезательно) маски сети должны быть одинаковы. Например если у вас два хоста с адресами 192.168.1.1 и 192.168.1.2 с маской 255.255.255.0. То они будут в одной сети 192.168.1.0 и соответственно будут видеть друг друга. Если же вы например создадите хост с адресом 192.168.1.1 и маской 255.255.255.0 и хост с маской 192.168.1.2 255.255.0.0 то ваш первый хост будет в сети 192.168.1. 0 а второй уже в сети 192.168.0.0. Как вы можете понять вторая сеть 192.168.0.0/16 включает в себя сеть 192.168.1.0/24, и поэтому компьютер с маской 16 будет видеть компьютер с маской 24, а вот наоборот уже врядли, так как для компьютера с маской 24 компьютер с маской 16 будет находится в другой сети, и следовательно чтобы передать данные на него он должен сначала отправить их на маршрутизатор, который в свою очередь уже будет маршрутизироавать из в сеть назначения.

В больших сетях как раз таки происходит разделение на сети и подсети, которые связаны между собой маршрутизаторами. В пределах одной сети устройствам задается одинаковый адрес сети и одинаковая маска подсети (на основание которой как раз таки и определяется адрес сети). Устройства имеющие одинаковый адрес сети будут видеть друг друга на прямую, а вот устройства имеющие разные адреса сети общаются через маршрутизаторы.

Следовательно для решения вашей проблемы задайте вашему ПК, и всем коммутаторам адреса из одно подсети, например из диапазона 192.168.1.1-254 с маской 255.255.255.0.

Спасибо большое за своевременную помощь и и развёрнутые понятные ответы!!!!!! Если что буду к Вам обращаться, с Вашего позволения!

незачто, обращайтесь буду рад попробовать помочь.

могу и я полюбопытствовать (почти первый раз циску вижу): есть 2 здания, поднят сторонней компанией канал объединяющий их в локальную сеть, на основе или впн или влан по оптике, fg-fom4e мультиплексор, за ним безголовый длинк. Но его решили заменить на циску, 2960. проблема в том что циска не воспринимает этот самый мультиплексор. я грешу на настройки (влан на циске и ip, что уж в мультиплексоре незнаю...) в локалке она пашет (через нее вам пишу) и пингуется... а когда переношу в пределы плекса ее не видно (пинга нет). Могли бы вы подсказать куда копать?:)

p.s. после плекса продолжается таже локальная сеть:0

Давайте попробуем разобраться вместе, но говорю сразу что fg-fom4e в глаза не видел не разу.
1. Если не затруднит нарисуйте схему вашей сети.
2. Видят ли fg-fom4e-мы на разных концах оптической линии друг друга.
3. Сбросьте пожалуйста конфиг 2960
4. Каким интерфейсом подключается 2960 к fg-fom4e

схема в процессе: cisco office--(оптика)-->fg-fom4e(мультиплексор)--(витая пара)-->cisco 2960 (про которую я спросил)
2. соответсвенно 2го fg-fom4e нет, это просто дешифратор оптики, без ip и индентификации в сети...
3. version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname c2960ssi
!
boot-start-marker
boot-end-marker
!
enable secret ######
enable password ######
!
username ###### privilege 15 secret ######
username ###### privilege 15 secret ######
username ###### privilege 15 secret ######
!
!
no aaa new-model
system mtu routing 1500
!
!
!
mls qos srr-queue output cos-map queue 1 threshold 3 5
mls qos srr-queue output cos-map queue 2 threshold 3 3 6 7
mls qos srr-queue output cos-map queue 3 threshold 3 2 4
mls qos srr-queue output cos-map queue 4 threshold 2 1
mls qos srr-queue output cos-map queue 4 threshold 3 0
mls qos
!
crypto pki trustpoint TP-self-signed-2304723456
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-2304723456
revocation-check none
rsakeypair TP-self-signed-2304723456
!
!
crypto pki certificate chain ######
quit
!
!
!
archive
log config
logging enable
hidekeys
path ftp://######.78/backup/$H-$T
write-memory
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
interface FastEthernet0/1
description main office
switchport mode trunk
switchport nonegotiate
speed 100
duplex full
mls qos trust cos
macro description cisco-wireless
spanning-tree bpduguard enable
!
interface FastEthernet0/2
description test
speed 100
duplex full
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface FastEthernet0/25
!
interface FastEthernet0/26
!
interface FastEthernet0/27
!
interface FastEthernet0/28
!
interface FastEthernet0/29
!
interface FastEthernet0/30
!
interface FastEthernet0/31
!
interface FastEthernet0/32
!
interface FastEthernet0/33
!
interface FastEthernet0/34
!
interface FastEthernet0/35
!
interface FastEthernet0/36
!
interface FastEthernet0/37
!
interface FastEthernet0/38
!
interface FastEthernet0/39
!
interface FastEthernet0/40
!
interface FastEthernet0/41
!
interface FastEthernet0/42
!
interface FastEthernet0/43
!
interface FastEthernet0/44
!
interface FastEthernet0/45
!
interface FastEthernet0/46
!
interface FastEthernet0/47
!
interface FastEthernet0/48
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
ip address ######.11 255.255.255.0
no ip route-cache
!
ip default-gateway ######.5
ip http server
ip http access-class 1
ip http authentication local
ip http secure-server
access-list 1 permit ######
access-list 1 permit ######
access-list 1 permit ######
!
line con 0
password #####
login
line vty 0 4
password #####
login
line vty 5 15
password #####
login
!
end

соответственно подключается по витой паре обычной. подсети одни и теже.

hostname @@@@@@
enable secret @@@@@@@@@@@@@@@@@@@@@@@@
enable password @@@@@@
no aaa new-model
vtp mode transparent
ip subnet-zero
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
vlan internal allocation policy ascending

vlan 15 name inet


vlan 111 name mange
vlan 2778
interface FastEthernet0/1 switchport access vlan 2778 switchport trunk encapsulation dot1q
switchport mode access
interface FastEthernet0/2 switchport access vlan 2778
switchport trunk encapsulation dot1q switchport mode access
interface FastEthernet0/3 switchport access vlan 2778
switchport trunk encapsulation dot1q switchport mode access

interface FastEthernet0/4 switchport access vlan 2778 switchport trunk encapsulation dot1q switchport mode access
interface FastEthernet0/5 switchport access vlan 2778
switchport trunk encapsulation dot1q switchport mode access

interface FastEthernet0/6
switchport access vlan 2778
switchport trunk encapsulation dot1q
switchport mode access
interface FastEthernet0/7
switchport access vlan 2778
switchport trunk encapsulation dot1q
switchport mode access
interface FastEthernet0/8
switchport access vlan 2778
switchport trunk encapsulation dot1q
switchport mode access
interface FastEthernet0/9
switchport access vlan 2778
switchport trunk encapsulation dot1q
switchport mode access
interface FastEthernet0/10
switchport access vlan 2778
switchport trunk encapsulation dot1q
switchport mode access
interface FastEthernet0/11
switchport access vlan 2778
switchport trunk encapsulation dot1q
switchport mode access
interface FastEthernet0/12
switchport access vlan 2778
switchport trunk encapsulation dot1q
switchport mode access

interface FastEthernet0/13
switchport access vlan 2778
switchport trunk encapsulation dot1q
switchport mode access

interface FastEthernet0/14
switchport access vlan 2778
switchport trunk encapsulation dot1q
switchport mode access

interface FastEthernet0/15
switchport access vlan 2778
switchport trunk encapsulation dot1q switchport mode access

interface FastEthernet0/16
switchport access vlan 2778
switchport trunk encapsulation dot1q
switchport mode access
interface FastEthernet0/17
switchport access vlan 2778
switchport trunk encapsulation dot1q
switchport mode access

interface FastEthernet0/18
switchport access vlan 2778
switchport trunk encapsulation dot1q
switchport mode access
interface FastEthernet0/19
switchport access vlan 2778
switchport trunk encapsulation dot1q
switchport mode access
interface FastEthernet0/20
switchport access vlan 2778
switchport trunk encapsulation dot1q
switchport mode access
interface FastEthernet0/21
switchport access vlan 15
switchport mode access

interface FastEthernet0/22
switchport access vlan 2778
switchport trunk encapsulation dot1q
switchport mode access
interface FastEthernet0/23
switchport access vlan 2778
switchport trunk encapsulation dot1q
switchport mode access
interface FastEthernet0/24
switchport access vlan 2778
switchport trunk encapsulation dot1q
switchport mode access

interface FastEthernet0/25
switchport access vlan 2778
switchport trunk encapsulation dot1q
switchport mode access
interface FastEthernet0/26
switchport access vlan 2778
switchport trunk encapsulation dot1q
switchport mode access
interface FastEthernet0/27
switchport access vlan 2778
switchport trunk encapsulation dot1q
switchport mode access

interface FastEthernet0/28
switchport access vlan 2778
switchport trunk encapsulation dot1q
switchport mode access
interface FastEthernet0/29
switchport access vlan 2778
switchport trunk encapsulation dot1q
switchport mode access
interface FastEthernet0/30
switchport access vlan 2778
switchport trunk encapsulation dot1q
switchport mode access

interface FastEthernet0/31
switchport access vlan 15
switchport mode access
interface FastEthernet0/32
switchport access vlan 2778
switchport trunk encapsulation dot1q
switchport mode access

interface FastEthernet0/33
switchport access vlan 2778
switchport trunk encapsulation dot1q
switchport mode access
interface FastEthernet0/34
switchport access vlan 2778
switchport trunk encapsulation dot1q
switchport mode access
interface FastEthernet0/35
switchport access vlan 2778
switchport trunk encapsulation dot1q
switchport mode access
interface FastEthernet0/36
switchport access vlan 2778
switchport trunk encapsulation dot1q
switchport mode access
interface FastEthernet0/37
switchport access vlan 2778
switchport trunk encapsulation dot1q
switchport mode access

interface FastEthernet0/38
switchport access vlan 2778
switchport trunk encapsulation dot1q
switchport mode access
interface FastEthernet0/39
switchport access vlan 2778
switchport trunk encapsulation dot1q
switchport mode access
interface FastEthernet0/40
switchport access vlan 2778
switchport trunk encapsulation dot1q
switchport mode access
interface FastEthernet0/41
switchport access vlan 2778
switchport trunk encapsulation dot1q
switchport mode access
interface FastEthernet0/42
switchport trunk encapsulation dot1q
switchport trunk native vlan 2778
switchport mode trunk

interface FastEthernet0/43
switchport access vlan 2778
switchport trunk encapsulation dot1q
switchport mode access
interface FastEthernet0/44
switchport access vlan 2778
switchport trunk encapsulation dot1q
switchport mode access
interface FastEthernet0/45
switchport access vlan 2778
switchport trunk encapsulation dot1q
switchport mode access
interface FastEthernet0/46
switchport access vlan 2778
switchport trunk encapsulation dot1q
switchport mode access
interface FastEthernet0/47
switchport access vlan 15
switchport mode access
interface FastEthernet0/48
switchport access vlan 2778
switchport trunk encapsulation dot1q
switchport mode access

interface GigabitEthernet0/1
switchport trunk encapsulation dot1q
switchport trunk native vlan 15
switchport mode trunk

interface GigabitEthernet0/2

interface GigabitEthernet0/3

interface GigabitEthernet0/4
interface Vlan1
ip address @@@.@@@.@@.@ 255.255.255.0
shutdown

interface Vlan111
description mng
ip address @@.@@.5.90 255.255.255.248
interface Vlan2778
ip address @@@.@@@.@@.3 255.255.255.0
ip classless
ip http server
control-plane
line con 0

line vty 0 4
password @@@@@@@ no login
line vty 5 15
password @@@@@@@
no login

end

соответсвеноо на первом порту висит соединение с тем присловутым fg-fom4e....

А если посмотреть состояние интерфейса порта на циске? И состояние порта на фоме? Может там что то интересное есть?

подскажите, как сделать управление с компа роутером подключенным к свичу?

Добрый день.
1.Задаете интерфейсу маршрутизатора и компьютера IP адреса из одной подсети. Проверяете их доступность друг с друга.
2.При необходимости настраиваете работу с VLAN на коммутаторе.
3.Производите настройку линий vty в соответсвии с примерами в статье с верху.
4.Подключаетесь.

спасибо, разобрался.
не совсем понял почему не работает управление через interface vlan, если подключить коммутатор к Ge интерфейсу, пока не заведешь подынтерфейс.
а вот в случае свичевой платы, все работает отлично

Если я правильно понял ваш вопрос, то ответ следующий:
В общем случае маршрутизаторы это устройства третьего уровня и ip адреса назначаются непосредственно их интерфейсам. Коммутаторы же, в общем случае это L2 устройства, и для того чтобы общаться с ними на сетевом уровне на коммутаторе необходимо создавать виртуальный интерфейс interface vlan, и уже ему назначать IP адрес

Как выйти из режима (config)# на # ?

команда exit или сочетание клавиш ctrl+z

У меня вопрос такой. Допустим есть несколько коммутаторов, они организованны в "пирамиду" (т.е. аксес левел и дистриб левел, транки между собой и тд. все вобщем как надо), соответственно каждый коммутатор разделен на несколько vlan'ов, как настроить доступ к любому коммутатору из любого vlan'а

Отправить комментарий