воскресенье, июля 17, 2016

Немного о RIP-1

Всем привет. Сегодня мы продолжим цикл наших статей, посвященных динамической маршрутизации и познакомимся с таким интересным старенькими протоколом как RIP-1.

Протокол RIP-1 (Routing Information Protoco v.1) относится к дистанционно векторным протоколам маршрутизации, имеет ряд недостатков которые мы сегодня чуть позже обсудим и на современных сетях практически не применяется.

В качестве примера для данной статьи будем использовать вот такую сеть:
Сеть для тестирования RIP-1
Сеть для тестирования RIP-1
Собирается она довольно просто. Добавляем на карту сети 3 маршрутизатора. Добавляем в маршрутизаторы 0 и 2 по модулю NM-2FE2W. Добавляем два компьютера и задаем им IP адреса согласно схеме. Далее переходим к настройке маршрутизаторов:

Маршрутизатор 0:
Router(config)#interface fastEthernet 0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface fastEthernet 0/1
Router(config-if)#ip address 192.168.4.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface fastEthernet 1/0
Router(config-if)#ip address 192.168.3.1 255.255.255.0
Router(config-if)#no shutdown

Маршрутизатор 1:
Router(config)#interface fastEthernet 0/0
Router(config-if)#ip address 192.168.4.2 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface fastEthernet 0/1
Router(config-if)#ip address 192.168.5.2 255.255.255.0
Router(config-if)#no shutdown

Маршрутизатор 2:
Router(config)#interface fastEthernet 0/0
Router(config-if)#ip address 192.168.5.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface fastEthernet 0/1
Router(config-if)#ip address 192.168.2.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface fastEthernet 1/0
Router(config-if)#ip address 192.168.3.2 255.255.255.0
Router(config-if)#no shutdown

После того как данная настройка выполнена, мы получаем сеть с тремя маршрутизаторами, между которыми не настроена маршрутизация. Тобишь с компьютера 0 мы не сможем попинговать компьютер 1. Решим данную проблему используя протокол динамической маршрутизации RIP-1, для этого выполним на маршрутизаторах следующие команды:

Маршрутизатор 0:
Router(config)#router rip
Router(config-router)#version 1
Router(config-router)#network 192.168.1.0
Router(config-router)#network 192.168.3.0
Router(config-router)#network 192.168.4.0

Маршрутизатор 1:
Router(config)#router rip
Router(config-router)#version 1
Router(config-router)#network 192.168.4.0
Router(config-router)#network 192.168.5.0

Маршрутизатор 2:
Router(config)#router rip
Router(config-router)#version 1
Router(config-router)#network 192.168.5.0
Router(config-router)#network 192.168.2.0
Router(config-router)#network 192.168.3.0

После выполнения данных команд дайте маршрутизаторам некоторое время и попробуйте пропинговать с компьютера 0 компьютер 1. Если все сделано верно, то пинги пойдут. Тобишь маршрутизация в нашей сети настроена.

Теперь давайте посмотрим таблицы маршрутизации всех маршрутизаторов, это можно сделать с помощью команды show ip route:

Маршрутизатор 0:
C    192.168.1.0/24 is directly connected, FastEthernet0/0
R    192.168.2.0/24 [120/1] via 192.168.3.2, 00:00:26, FastEthernet1/0
C    192.168.3.0/24 is directly connected, FastEthernet1/0
C    192.168.4.0/24 is directly connected, FastEthernet0/1
R    192.168.5.0/24 [120/1] via 192.168.4.2, 00:00:11, FastEthernet0/1
                    [120/1] via 192.168.3.2, 00:00:26, FastEthernet1/0

Маршрутизатор 1:
R    192.168.1.0/24 [120/1] via 192.168.4.1, 00:00:22, FastEthernet0/0
R    192.168.2.0/24 [120/1] via 192.168.5.1, 00:00:18, FastEthernet0/1
R    192.168.3.0/24 [120/1] via 192.168.4.1, 00:00:22, FastEthernet0/0
                    [120/1] via 192.168.5.1, 00:00:18, FastEthernet0/1
C    192.168.4.0/24 is directly connected, FastEthernet0/0
C    192.168.5.0/24 is directly connected, FastEthernet0/1

Маршрутизатор 2:
R    192.168.1.0/24 [120/1] via 192.168.3.1, 00:00:00, FastEthernet1/0
C    192.168.2.0/24 is directly connected, FastEthernet0/1
C    192.168.3.0/24 is directly connected, FastEthernet1/0
R    192.168.4.0/24 [120/1] via 192.168.5.2, 00:00:04, FastEthernet0/0
                    [120/1] via 192.168.3.1, 00:00:00, FastEthernet1/0
C    192.168.5.0/24 is directly connected, FastEthernet0/0

Разберемся в этой информации для маршрутизатора 0. Маршрутизатор 0 имеет три непосредственно подключенные к нему сети 192.168.1.0/24, 192.168.3.0/24, 192.168.4.0/24, данные сети обозначены значком С.  Данные об этих сетях маршрутизатор обнаруживает сам, без всякой динамической маршрутизации. И рассылает информацию о этих сетях на другие маршрутизаторы с помощью протокола RIP-1. Данные о сети 192.168.2.0/24 маршрутизатор получил с помощью протокола RIP-1 от других маршрутизаторов, об этом свидетельствует значок R. Для того чтобы попасть в данную сеть маршрутизатору 0 необходимо отправить данные на IP адрес 192.168.3.2 через интерфейс  FastEthernet1/0. Так же маршрутизатор 0 знает и о сети 192.168.5.0/24. Данные о ней также получены с помощью протокола RIP-1. Но к данной сети имеется уже два маршрута.  Наверное у вас возникает вопрос, почему же тогда для сети 192.168.2.0/24 был только 1 маршрут, ведь к ней можно попасть двумя путями? Напоминаю вам, что протокол RIP-1 это дистанционно векторный протокол маршрутизации и он выбирает наилучший маршрут на основании числа промежуточных узлов. Действительно к сети 192.168.2.0/24 существует 2 маршрута, но они не равноценные. Один из них идет через 1 промежуточный узел, а  второй через 2. Поэтому протокол RIP-1 выбрал наиболее предпочтительный маршрут и поместил его в свою в таблицу маршрутизации. Так как к сети 192.168.5.0/24 ведет два равноценных маршрута, то протокол RIP-1 добавил их оба в таблицу маршрутизации.







Теперь поговорим о недостатках RIP-1. Как мы уже говорили ранее, RIP-1 это дистанционно векторный протокол маршрутизации, со всеми вытекающими недостатками данного типа протоколов маршрутизации. Протоколу RIP-1 абсолютно начихать на пропускную способность каналов связи. Он лишь считает число узлов на своем пути. Например, на данной схеме, вы легко можете порезать скорость интерфейсов между маршрутизаторами 0 и 2, до 10 Мбит/c , оставив скорость интерфейсов между остальными маршрутизаторами равной 100 Мбит, после чего произвести трассировку от ПК 0 до ПК 1. Маршрут прохождения пакетов останется неизменным они будут идти по пути  с наименьшим числом узлов.

Еще одним, серьезным недостатком протокола RIP-1 является отсутствие поддержки в нем бесклассовой адресации. Например если мы пожелаем задать интерфейсам FastEthernet1/0 маршрутизаторов 0 и 2 ip адреса типа 172.20.20.1/30 и 172.20.20.2/30, прописав команду network 172.20.20.0 на всех маршрутизаторах мы увидим интересную картину посмотрев таблицу маршрутизации маршрутизатора 1:

R    172.20.0.0/16 [120/1] via 192.168.4.1, 00:00:11, FastEthernet0/0
                   [120/1] via 192.168.5.1, 00:00:07, FastEthernet0/1
R    192.168.1.0/24 [120/1] via 192.168.4.1, 00:00:11, FastEthernet0/0
R    192.168.2.0/24 [120/1] via 192.168.5.1, 00:00:07, FastEthernet0/1
C    192.168.4.0/24 is directly connected, FastEthernet0/0
C    192.168.5.0/24 is directly connected, FastEthernet0/1

Как видите протокол RIP-1 проигнорировал наше пожелание использовать безскласовую адресацию и представил сеть 172.20.20.0/30, как 172.20.0.0/16, то есть сеть класса B. Конечно в нашем примере это не критично, но это надо иметь ввиду.

Приведенный выше пример немного не корректен. Более правильный вариант показывающий что RIP-1 не поддерживает бесклассовую адресацию приведен в статье Переходим от RIP-1 к RIP-2.

На сегодня это все чем я хотел с вами поделиться, до новых встреч.

2 коммент.:

Спасибо Вам большое за познавательные статьи! Хороший понятный материал для начинающих

Отправить комментарий