Переходи скоре...

воскресенье, сентября 04, 2016

Интеграция статических маршрутов в протоколы динамической маршрутизации

Добрый день уважаемые читатели! Сегодня мы разберем, как можно распространять, статические маршруты, имеющиеся на ваших маршрутизаторах, на другие маршрутизаторы при помощи протоколов динамической маршрутизации. Поехали.
И так. Пусть у нас есть вот такая сеть:

Сеть для демонстрации интеграции статических маршрутов

Конфигурации устройств следующие:

Маршрутизатор 0:

interface FastEthernet0/0
 ip address 192.168.1.1 255.255.255.0
interface FastEthernet0/1
 ip address 172.20.20.1 255.255.255.0
router rip
 version 2
 network 192.168.1.0

Маршрутизатор 1:

interface FastEthernet0/0
 ip address 192.168.1.2 255.255.255.0
interface FastEthernet0/1
 ip address 192.168.2.1 255.255.255.0
router rip
 version 2
 network 192.168.1.0
 network 192.168.2.0

Маршрутизатор 2:

interface FastEthernet0/0
 ip address 192.168.2.2 255.255.255.0
router rip
 version 2
 network 192.168.2.0

Теперь давайте возьмем и добавим на маршрутизатор 0, статический маршрут, например вот такой:

ip route 172.20.30.0 255.255.255.0 172.20.20.2







Посмотрим содержимое его таблицы маршрутизации:

C       172.20.20.0 is directly connected, FastEthernet0/1
S       172.20.30.0 [1/0] via 172.20.20.2
C    192.168.1.0/24 is directly connected, FastEthernet0/0
R    192.168.2.0/24 [120/1] via 192.168.1.2, 00:00:26, FastEthernet0/0

Как видите тут мы имеем две непосредственно подключенные сети, один маршрут полученный по протоколу RIP и один маршрут который мы статически добавили своими ручками.

Теперь давайте посмотрим содержимое таблицы маршрутизации маршрутизатора 2:

R    192.168.1.0/24 [120/1] via 192.168.2.1, 00:00:22, FastEthernet0/0
C    192.168.2.0/24 is directly connected, FastEthernet0/0

Как видите этот маршрутизатор даже не подозревает о том, что мы добавляли какой то статический маршрут на маршрутизаторе 0. 

Теперь давайте сделаем так, чтобы остальные маршрутизаторы сети, узнали об этом статическом маршруте. Для этого на маршрутизаторе 0 выполним команды:

Router(config)#router rip 
Router(config-router)#redistribute static 

Теперь давайте посмотрим содержимое таблицы маршрутизации маршрутизатора 2:

R    172.20.0.0/16 [120/2] via 192.168.2.1, 00:00:11, FastEthernet0/0
R    192.168.1.0/24 [120/1] via 192.168.2.1, 00:00:11, FastEthernet0/0
C    192.168.2.0/24 is directly connected, FastEthernet0/0

Как видите там появился маршрут к сети 172.20.0.0/16, в которую входит подсеть 172.20.30.0. Заметьте что этот маршрут помечен буквой R а не буквой S, так как хотя этот маршрут и был статически добавлен на маршрутизатор 0, но на маршрутизатор 2 он был доставлен динамическим протоколом RIP.

Аналогичная картина будет и на маршрутизаторе 1:

R    172.20.0.0/16 [120/2] via 192.168.2.1, 00:00:11, FastEthernet0/0
R    192.168.1.0/24 [120/1] via 192.168.2.1, 00:00:11, FastEthernet0/0
C    192.168.2.0/24 is directly connected, FastEthernet0/0

Вот так! На сегодня это все!

3 коммент.:

Спасибо за очередной урок! Как всегда, емкая и полезная информация.

Hello, Dear ladies! The best Escort agency offer adult erotic sex escort Job as a Escorts Girl Job in Delhi. Dear girls, welcome to our agency who provide you the best Female Escorts Job in Delhi which exist from many year! We are escort agency, but we work with different areas in India with luxury worldwide models. If you really want and serious about what we offer like: sex love Call Girls job in Delhi?

The number of clients and works depends on the appearance of the girl, services, the quality of real photographs and selfies, and of course on a positive attitude as Escorts Girl Job in Delhi. We have the highest prices in Delhi escort and the highest percentage for girls. In escort companions in the Delhi, Russian girls have 60% of the income from the transaction, for example for an hour it is 15000-30000 Rs. so Join as a Female Escorts Job in Delhi. We are also open for Call Girls job in Delhi.

Отправить комментарий


Поддержи проект "Сетевые заморочки"

руб.